summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-02-10 15:11:09 +0000
committerEmil Velikov <[email protected]>2015-02-12 13:19:26 +0000
commitc39dbfdd0f764b1aaa7319b4694e7335692993dd (patch)
tree56c97237bba4abac064de035914361608323ca40 /src/gallium/auxiliary/Makefile.am
parent153539bd9d4445b504110958306f00632222f840 (diff)
auxiliary/vl: bring back the VL code for the dri targets
With commit c642e87d9f4(auxiliary/vl: rework the build of the VL code) we split out the VL code into a separate static library that was meant to be used by the VL targets alone - va, vdpau, xvmc. The commit failed to consider the way we handle vdpau-gl interop and broke it. Bring back the functionality by keeping the vl <> vl_stub separation as requrested by Christian. v2: Update the omx target as well. Update mesa-stable email address. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=86837 Cc: "10.5" <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Tested-by: Andy Furniss <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am19
1 files changed, 15 insertions, 4 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 1053ce4ee1a..453282a9609 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -53,9 +53,7 @@ libgalliumvl_stub_la_SOURCES = \
if NEED_GALLIUM_VL
-noinst_LTLIBRARIES += libgalliumvl.la
-
-libgalliumvl_la_CFLAGS = \
+COMMON_VL_CFLAGS = \
$(AM_CFLAGS) \
$(VL_CFLAGS) \
$(LIBDRM_CFLAGS) \
@@ -63,14 +61,27 @@ libgalliumvl_la_CFLAGS = \
-DPIPE_SEARCH_DIR=\"$(libdir)/gallium-pipe\"
if HAVE_GALLIUM_STATIC_TARGETS
-libgalliumvl_la_CFLAGS += \
+COMMON_VL_CFLAGS += \
-DGALLIUM_STATIC_TARGETS=1
endif # HAVE_GALLIUM_STATIC_TARGETS
+noinst_LTLIBRARIES += libgalliumvl.la
+
+libgalliumvl_la_CFLAGS = \
+ $(COMMON_VL_CFLAGS)
+
libgalliumvl_la_SOURCES = \
$(VL_SOURCES)
+noinst_LTLIBRARIES += libgalliumvlwinsys.la
+
+libgalliumvlwinsys_la_CFLAGS = \
+ $(COMMON_VL_CFLAGS)
+
+libgalliumvlwinsys_la_SOURCES = \
+ $(VL_WINSYS_SOURCES)
+
endif
EXTRA_DIST = \