summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-01-18 16:35:28 +0000
committerTom Stellard <[email protected]>2013-01-24 15:45:32 +0000
commit0261b4ecdb80973b3a00cbe6a9a77c6085ef3dff (patch)
treea54ae12db52255444037e969789e858d0b5bf6c0 /src/gallium/auxiliary/Makefile.am
parentcf69a591e1ad16b590c9ae2eba0da6fa6c4fc741 (diff)
Revert "Revert "targets/opencl: Link against libgallium.la instead of libgallium.a""
This reverts commit 7824ab807050c03c6df01c44774914dcbef88248. Now that we force linking with LLVM shared libs when building clover, we can link against libgallium.la with no problems.
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 49792930a22..a4eee4773c2 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -45,9 +45,3 @@ util/u_format_srgb.c: $(srcdir)/util/u_format_srgb.py
util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_pack.py $(srcdir)/util/u_format_parse.py $(srcdir)/util/u_format.csv
$(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
-
-# XXX: As a work around for https://bugs.freedesktop.org/show_bug.cgi?id=59334
-# clover needs to link against libgallium.a. Delete this once we have a real
-# fix for this bug.
-all-local: libgallium.la
- ln -f $(builddir)/.libs/libgallium.a $(builddir)/libgallium.a