summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-02-16 18:22:16 +0000
committerEmil Velikov <[email protected]>2015-02-18 11:02:50 +0000
commitdd7b6670a29ff3ed48ba44a9fecd1890363d914f (patch)
treec75af22e84bc36d7633743f3c1dd222a333baf2e /src/gallium/auxiliary/Makefile.am
parent3018c4a56aab2ac1d8d5b228e6cbf13eea68b790 (diff)
auxiliary/vl: Build vl_winsys_dri.c only when needed.
With commit c39dbfdd0f7(auxiliary/vl: bring back the VL code for the dri targets) we did not fully consider users of dri-swrast alone. Thus we ended up trying to compile the dri2 specific code on platform which lack it - Cygwin for example. Cc: "10.5" <[email protected]> Reported-by: Jon TURNEY <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Jon TURNEY <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 453282a9609..6a628e948aa 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -74,6 +74,8 @@ libgalliumvl_la_CFLAGS = \
libgalliumvl_la_SOURCES = \
$(VL_SOURCES)
+if NEED_GALLIUM_VL_WINSYS
+
noinst_LTLIBRARIES += libgalliumvlwinsys.la
libgalliumvlwinsys_la_CFLAGS = \
@@ -84,6 +86,8 @@ libgalliumvlwinsys_la_SOURCES = \
endif
+endif
+
EXTRA_DIST = \
SConscript \
indices/u_indices.c \