summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorAlexander von Gluck IV <[email protected]>2013-10-12 17:12:31 +0000
committerAlexander von Gluck IV <[email protected]>2013-10-14 23:00:55 -0500
commitce8eadb6e8adc24f675b364e0620dbf1c9e079a8 (patch)
treedb0054c851e503805e9e61f98ea5f69e67b3a4fc /src/gallium/auxiliary/Makefile.am
parent7a2e9f9778473a812ce372a25cc4b6e791b355cf (diff)
build: remove forced -fno-rtti
* As discussed on the mailing list, forced no-rtti breaks C++ public API's such as the Haiku C++ libGL.so * -fno-rtti *can* be still set however instead of blindly forcing -fno-rtti, we can rely on the llvm-config --cppflags output. If the system llvm is built without rtti (default), the no-rtti flag will be present in llvm-config --cppflags (which we pick up on) If llvm is built with rtti (REQUIRES_RTTI=1), then -fno-rtti is removed from llvm-config --cppflags. * We could selectively add / remove rtti from various components, however mixing rtti and non-rtti code is tricky and could introduce missing symbols. * This needs impact tested. Reviewed-by: Francisco Jerez <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 670e1248de9..2d2d8d4846e 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -25,12 +25,6 @@ AM_CXXFLAGS += \
$(GALLIUM_CFLAGS) \
$(LLVM_CXXFLAGS)
-if LLVM_NEEDS_FNORTTI
-
-AM_CXXFLAGS += -fno-rtti
-
-endif
-
libgallium_la_SOURCES += \
$(GALLIVM_SOURCES) \
$(GALLIVM_CPP_SOURCES)