summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-11-09 04:44:15 +0000
committerEmil Velikov <[email protected]>2014-11-26 20:09:09 +0000
commitf093c1c8ec1bce50d9338533ce775b564358fbeb (patch)
treea4a8d22fe542286f90294eb76432f349b82be406 /src/gallium/auxiliary/Makefile.am
parent2dbaedaf109aad822d72bd0e761c506efbb29ec4 (diff)
auxiliary/vl: add galliumvl_stub.la
Will be used by the non-VL targets, to stub out the functions called by the drivers. The entry point to those are within the VL state-trackers, yet the compiler cannot determine that at link time. Thus we'll need to stub them out to prevent unresolved symbols in the dri, egl, gbm and pipe-loader targets. v2: Rebase. Cc: Christian König <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 19037a271ef..bea9c550810 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -46,6 +46,11 @@ util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_
$(AM_V_at)$(MKDIR_P) util
$(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
+
+noinst_LTLIBRARIES += libgalliumvl_stub.la
+libgalliumvl_stub_la_SOURCES = \
+ $(VL_STUB_SOURCES)
+
EXTRA_DIST = \
Android.mk SConscript \
indices/u_indices.c \