summaryrefslogtreecommitdiffstats
path: root/src/gallium/Makefile.am
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2017-09-04 22:36:34 +0200
committerMarek Olšák <[email protected]>2018-02-07 22:08:34 +0100
commit6f82b8d8d0a986aac28e7bec47fc313fb950475c (patch)
tree69eac15198a19e2e16447b5d4774a5c787af677e /src/gallium/Makefile.am
parentdef09f8db0ce77fc41f5188418e0b06356ce59b7 (diff)
gallium: build ddebug, noop, rbug, trace as part of auxiliary
Building gallium is faster by 7.5 seconds on a 4core/8thread 3GHz CPU. (gallium build time is reduced by 15% when building only radeonsi) Non-recursive makefiles are great!
Diffstat (limited to 'src/gallium/Makefile.am')
-rw-r--r--src/gallium/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/gallium/Makefile.am b/src/gallium/Makefile.am
index af010c89f8d..81eabef1061 100644
--- a/src/gallium/Makefile.am
+++ b/src/gallium/Makefile.am
@@ -11,12 +11,6 @@ SUBDIRS += auxiliary/pipe-loader
## Gallium pipe drivers and their respective winsys'
##
-SUBDIRS += \
- drivers/ddebug \
- drivers/noop \
- drivers/trace \
- drivers/rbug
-
## freedreno/msm/kgsl
if HAVE_GALLIUM_FREEDRENO
SUBDIRS += drivers/freedreno winsys/freedreno/drm
@@ -188,6 +182,12 @@ endif
EXTRA_DIST += \
include \
+ drivers/noop/SConscript \
+ drivers/rbug/README \
+ drivers/rbug/SConscript \
+ drivers/trace/trace.xsl \
+ drivers/trace/README \
+ drivers/trace/SConscript \
state_trackers/README \
state_trackers/wgl targets/libgl-gdi \
targets/graw-gdi targets/graw-null targets/graw-xlib \