summaryrefslogtreecommitdiffstats
path: root/src/freedreno/vulkan/meson.build
diff options
context:
space:
mode:
authorChia-I Wu <[email protected]>2019-02-08 13:45:53 -0800
committerChia-I Wu <[email protected]>2019-03-11 10:02:13 -0700
commit24af64baa531f9ac490bc5de433b2b2b52a3ccee (patch)
tree5748e4433953a5b67f192e8039b50b483312ea08 /src/freedreno/vulkan/meson.build
parentae82b5df88b9b307c2b7ce6f0f9b59332c83e362 (diff)
turnip: preliminary support for Wayland WSI
Diffstat (limited to 'src/freedreno/vulkan/meson.build')
-rw-r--r--src/freedreno/vulkan/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/freedreno/vulkan/meson.build b/src/freedreno/vulkan/meson.build
index 6c0f7d91853..40a0105e9ae 100644
--- a/src/freedreno/vulkan/meson.build
+++ b/src/freedreno/vulkan/meson.build
@@ -71,12 +71,19 @@ libtu_files = files(
'tu_shader.c',
'tu_util.c',
'tu_util.h',
+ 'tu_wsi.c',
'vk_format.h',
)
tu_deps = []
tu_flags = []
+if with_platform_wayland
+ tu_deps += dep_wayland_client
+ tu_flags += '-DVK_USE_PLATFORM_WAYLAND_KHR'
+ libtu_files += files('tu_wsi_wayland.c')
+endif
+
libvulkan_freedreno = shared_library(
'vulkan_freedreno',
[libtu_files, tu_entrypoints, tu_extensions_c, vk_format_table_c],
@@ -84,10 +91,12 @@ libvulkan_freedreno = shared_library(
inc_common,
inc_compiler,
inc_vulkan_util,
+ inc_vulkan_wsi,
inc_freedreno,
],
link_with : [
libvulkan_util,
+ libvulkan_wsi,
libmesa_util,
libfreedreno_drm, # required by ir3_shader_get_variant, which we don't use
libfreedreno_ir3,
@@ -101,6 +110,7 @@ libvulkan_freedreno = shared_library(
dep_thread,
dep_valgrind,
idep_nir,
+ tu_deps,
],
c_args : [c_vis_args, no_override_init_args, tu_flags],
link_args : [ld_args_bsymbolic, ld_args_gc_sections],