summaryrefslogtreecommitdiffstats
path: root/src/freedreno/vulkan/meson.build
diff options
context:
space:
mode:
authorChia-I Wu <[email protected]>2019-02-20 09:53:47 -0800
committerChia-I Wu <[email protected]>2019-03-11 10:02:13 -0700
commit970a8fec96440dc749d309505dfa17e8db028484 (patch)
treea41a7cd28a8d069d0b73a387653b99f7801541dd /src/freedreno/vulkan/meson.build
parent9e0d87878735ee65b8b5529640bc18139d0b7b9f (diff)
turnip: preliminary support for shader modules
Save SPIR-V in tu_shader_module. Tranlation to NIR happens in tu_shader_create, and compilation to binary code happens in tu_shader_compile. Both will be called during pipeline creation.
Diffstat (limited to 'src/freedreno/vulkan/meson.build')
-rw-r--r--src/freedreno/vulkan/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/freedreno/vulkan/meson.build b/src/freedreno/vulkan/meson.build
index 3b2624e499e..6c0f7d91853 100644
--- a/src/freedreno/vulkan/meson.build
+++ b/src/freedreno/vulkan/meson.build
@@ -68,6 +68,7 @@ libtu_files = files(
'tu_pipeline_cache.c',
'tu_private.h',
'tu_query.c',
+ 'tu_shader.c',
'tu_util.c',
'tu_util.h',
'vk_format.h',
@@ -88,6 +89,8 @@ libvulkan_freedreno = shared_library(
link_with : [
libvulkan_util,
libmesa_util,
+ libfreedreno_drm, # required by ir3_shader_get_variant, which we don't use
+ libfreedreno_ir3,
],
dependencies : [
dep_dl,