aboutsummaryrefslogtreecommitdiffstats
path: root/src/freedreno/vulkan/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2020-07-11 10:17:30 +0200
committerMarge Bot <[email protected]>2020-07-14 09:34:54 +0000
commitf95637f01a7bc9054638fff0c9225cab0e13b98a (patch)
treeafbaa969c1f76f1ab786d6a09ab74109b03cc8c2 /src/freedreno/vulkan/meson.build
parent3ed104b2aa14818f789cbe79de8c6742cc7b5ad7 (diff)
meson: fix android vulkan build
Android doesn't have `pthread_cancel()` and is unlikely to ever implement it [1], but `wsi_common_display.c` needs it (or an alternative). Let's just disable the platform on Android (as it used to be before 448eb19158f483d807ef). [1] https://android-review.googlesource.com/c/platform/bionic/+/1215779/1/docs/status.md Fixes: 448eb19158f483d807ef ("vulkan: automatically compile the `display` platform when available") Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Nataraj Deshpande <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/5860>
Diffstat (limited to 'src/freedreno/vulkan/meson.build')
-rw-r--r--src/freedreno/vulkan/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/freedreno/vulkan/meson.build b/src/freedreno/vulkan/meson.build
index eab543e1c12..8696f246da0 100644
--- a/src/freedreno/vulkan/meson.build
+++ b/src/freedreno/vulkan/meson.build
@@ -81,7 +81,7 @@ if with_platform_wayland
libtu_files += files('tu_wsi_wayland.c')
endif
-if system_has_kms_drm
+if system_has_kms_drm and not with_platform_android
tu_flags += '-DVK_USE_PLATFORM_DISPLAY_KHR'
libtu_files += files('tu_wsi_display.c')
endif