aboutsummaryrefslogtreecommitdiffstats
path: root/src/freedreno/ir3/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2020-04-23 12:01:04 -0700
committerMarge Bot <[email protected]>2020-04-27 19:35:00 +0000
commit1462b00391711ff86350e802c1a3e5075a3a1632 (patch)
tree20938f5090e62b3b57bde9afd39ad31584bd8007 /src/freedreno/ir3/meson.build
parent90984ba853297993221027c49ce31959c1634790 (diff)
freedreno/ir3: Add a unit test for our disassembler.
Makes sure that we can maintain consistent output from our disassembly as we refactor. I've only included stuff that matches qcom's disasm so far. Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4736>
Diffstat (limited to 'src/freedreno/ir3/meson.build')
-rw-r--r--src/freedreno/ir3/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/freedreno/ir3/meson.build b/src/freedreno/ir3/meson.build
index a9268b04c36..5299ecad744 100644
--- a/src/freedreno/ir3/meson.build
+++ b/src/freedreno/ir3/meson.build
@@ -111,3 +111,13 @@ libfreedreno_ir3 = static_library(
build_by_default : false,
)
+test('ir3_disasm',
+ executable(
+ 'ir3_disasm',
+ 'tests/disasm.c',
+ link_with: libfreedreno_ir3,
+ dependencies: idep_mesautil,
+ include_directories: [inc_freedreno, inc_include, inc_src],
+ ),
+ suite: ['freedreno'],
+)