summaryrefslogtreecommitdiffstats
path: root/src/egl/wayland/wayland-egl/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <[email protected]>2012-01-24 20:38:01 +0100
committerBenjamin Franzke <[email protected]>2012-01-26 10:07:11 +0100
commit8b902056d53e0e14f7d58ac7f95091ab06abc72e (patch)
tree5910a2c884eb8cecf8d91943bea1874798689cf5 /src/egl/wayland/wayland-egl/Makefile.am
parentdc435ae774b1deed3d00b7c7d33133c08b626737 (diff)
automake: src/egl/wayland
So we can use the wayland scanner makro, which is way better than our previous runtime-pkgconfig hack. Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/egl/wayland/wayland-egl/Makefile.am')
-rw-r--r--src/egl/wayland/wayland-egl/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/egl/wayland/wayland-egl/Makefile.am b/src/egl/wayland/wayland-egl/Makefile.am
new file mode 100644
index 00000000000..a19a5fcde1a
--- /dev/null
+++ b/src/egl/wayland/wayland-egl/Makefile.am
@@ -0,0 +1,9 @@
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = wayland-egl.pc
+
+AM_CFLAGS = $(DEFINES)
+
+lib_LTLIBRARIES = libwayland-egl.la
+noinst_HEADERS = wayland-egl-priv.h
+libwayland_egl_la_SOURCES = wayland-egl.c
+libwayland_egl_la_LDFLAGS = -version-info 1