summaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-20 17:34:51 -0700
committerEric Anholt <[email protected]>2017-10-23 10:14:40 -0700
commit77f7ef0287cee23d411b1a2e750d281efe425ff3 (patch)
treeaa49a75db0e01d9ade8c7b087a5013fe07f114b9 /src/egl/meson.build
parentf9ccfda9bc8166f833fdb64adf1eca5b8ee69251 (diff)
meson: fix egl build for meson version < 0.43
Meson 0.43 added the ability to pass nested lists to include_directories, so the code that we have works for 0.43, but not for 0.42. This patch changes the include_directories list to be flat so it works with 0.42 fixes: 108d257a16859898f5c ("meson: build libEGL") Tested-by: Vinson Lee <[email protected]> Reviewed-by: Rhys Kidd <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Signed-off-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 8ea8a5bbb69..ea7ae06761f 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -21,7 +21,9 @@
c_args_for_egl = []
link_for_egl = []
deps_for_egl = []
-incs_for_egl = []
+incs_for_egl = [
+ inc_include, inc_src, inc_loader, inc_gbm, include_directories('main'),
+]
files_egl = files(
'main/eglapi.c',
'main/eglapi.h',
@@ -159,10 +161,7 @@ libegl = shared_library(
'-D_EGL_BUILT_IN_DRIVER_DRI2',
'-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
],
- include_directories : [
- incs_for_egl, inc_include, inc_src, inc_loader, inc_gbm,
- include_directories('main'),
- ],
+ include_directories : incs_for_egl,
link_with : [link_for_egl, libloader, libxmlconfig, libglapi, libmesa_util],
link_args : [ld_args_bsymbolic, ld_args_gc_sections],
dependencies : [deps_for_egl, dep_dl, dep_libdrm, dep_clock, dep_thread],