summaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-11-02 23:24:00 +0000
committerEric Engestrom <[email protected]>2017-11-07 10:47:20 +0000
commit5be1b1a8ce6c635cf0310d2b97056a2b8f11a601 (patch)
treeef0232f3f79b0920e5fe52b80982aa4d80a40ef8 /src/egl/meson.build
parent0084f4a42290ab54c185c9284a5670d4da4fc66e (diff)
meson: standardize .so version to major.minor.patch
This `version` field defines the filename for the .so. The plan .so as well as .so.$major are always symlinks to this. Unless I'm mistaken, only the major is ever used, so this shouldn't matter, but for consistency with autotools (and in case it does matter), let's always have all 3 major.minor.patch components. (The soname isn't affected, and is always .so.$major) Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 67ca8cef921..36b1d9e41b0 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -145,7 +145,7 @@ if not with_glvnd
egl_lib_version = '1.0.0'
else
egl_lib_name = 'EGL_mesa'
- egl_lib_version = '0'
+ egl_lib_version = '0.0.0'
files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
install_data(