summaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-10-24 16:08:15 +0100
committerEric Engestrom <[email protected]>2017-10-30 16:32:05 +0000
commitc5ec1556859b7d33637c9fad13d3473c7b2f9eb3 (patch)
tree3538e85b0c9afe7f3fe0f7fcbea4c9a5d5aee0d5 /src/egl/meson.build
parent6403efbe7458d05cf117adb41c8a152ed6e28bdd (diff)
meson: wire up egl/android
Cc: Rob Herring <[email protected]> Cc: Tomasz Figa <[email protected]> Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index ea7ae06761f..cc51671f9d8 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -129,7 +129,10 @@ if with_platform_wayland
'wayland/wayland-egl', 'wayland/wayland-drm',
)
endif
-# TODO: android
+if with_platform_android
+ deps_for_egl += dep_android
+ files_egl += files('drivers/dri2/platform_android.c')
+endif
# TODO: glvnd