summaryrefslogtreecommitdiffstats
path: root/src/egl/main/SConscript
diff options
context:
space:
mode:
authorJose Fonseca <[email protected]>2015-03-03 16:01:22 +0000
committerJose Fonseca <[email protected]>2015-03-04 11:01:42 +0000
commit5564c361b5cc1f5ec4be3622d7f9be601e3c268a (patch)
treeedd2e212e86ad94257f5b4bf80659e4affee82a0 /src/egl/main/SConscript
parent17b2825d760fb6a7b643e5f9c067d249a582cfdb (diff)
st/egl: Remove.
Largely superseeded by src/egl, and WGL/GLX_EXT_create_context_es_profile extensions. Note this will break Android.mk with gallium drivers -- somebody familiar with that build infrastructure will need to update it to use gallium drivers through egl_dri2. v2: Remove the _EGL_BUILT_IN_DRIVER_GALLIUM define from src/egl/main/Android.mk; and update the src/egl/main/Sconscript to create a SharedLibrary, add versioning, create symlink - copy the bits from egl-static, per Emil Velikov. Reviewed-by: Emil Velikov <[email protected]> v3: Disallow undefined symbols in libEGL.so. Update release notes
Diffstat (limited to 'src/egl/main/SConscript')
-rw-r--r--src/egl/main/SConscript12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/egl/main/SConscript b/src/egl/main/SConscript
index 5d0073e14e0..399c020c2d0 100644
--- a/src/egl/main/SConscript
+++ b/src/egl/main/SConscript
@@ -7,7 +7,6 @@ Import('*')
env = env.Clone()
env.Append(CPPDEFINES = [
- '_EGL_BUILT_IN_DRIVER_GALLIUM',
'_EGL_DRIVER_SEARCH_DIR=\\"\\"',
])
@@ -38,6 +37,9 @@ else:
egl_dri2,
libloader,
])
+ # Disallow undefined symbols
+ if env['platform'] != 'darwin':
+ env.Append(SHLINKFLAGS = ['-Wl,-z,defs'])
env.Append(CPPPATH = [
'#/include',
@@ -47,9 +49,11 @@ env.Append(CPPPATH = [
# parse Makefile.sources
egl_sources = env.ParseSourceList('Makefile.sources', 'LIBEGL_C_FILES')
-egl = env.ConvenienceLibrary(
- target = 'egl',
+egl = env.SharedLibrary(
+ target = 'EGL',
source = egl_sources,
)
-Export('egl')
+egl = env.InstallSharedLibrary(egl, version=(1, 0, 0))
+
+env.Alias('egl', egl)