summaryrefslogtreecommitdiffstats
path: root/src/egl/main/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2014-05-11 14:38:52 +0100
committerJon TURNEY <[email protected]>2014-05-23 15:24:01 +0100
commitff90a8784cf22ada7bba75f90460b063818abda7 (patch)
treec9c83e89685a4925acdbc7158d39995fa0bff445 /src/egl/main/Makefile.am
parente0372239a5b716de21b5f4c7a4a7d8b4a74a51cb (diff)
Fix build for darwin
Fix build for darwin, when ./configured --disable-driglx-direct - darwin ld doesn't support -Bsymbolic or --version-script, so check if ld supports those options before using them - define GLX_ALIAS_UNSUPPORTED as config/darwin used to, as aliasing of non-weak symbols isn't supported - default to -with-dri-drivers=swrast v2: Use -Wl,-Bsymbolic, as before, not -Bsymbolic Test that ld --version-script works, rather than just looking for it in ld --help Don't use -Wl,--no-undefined on darwin, either Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Jeremy Huddleston Sequoia <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/egl/main/Makefile.am')
-rw-r--r--src/egl/main/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/main/Makefile.am b/src/egl/main/Makefile.am
index 23207db8ae1..38758a0abdd 100644
--- a/src/egl/main/Makefile.am
+++ b/src/egl/main/Makefile.am
@@ -75,7 +75,7 @@ libEGL_la_LIBADD = \
libEGL_la_LDFLAGS = \
-no-undefined \
-version-number 1:0 \
- -Wl,-Bsymbolic \
+ $(BSYMBOLIC) \
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)