summaryrefslogtreecommitdiffstats
path: root/src/egl/main/Makefile.am
diff options
context:
space:
mode:
authorSarah Sharp <[email protected]>2014-05-06 12:10:56 -0700
committerChad Versace <[email protected]>2014-05-20 11:31:32 -0700
commitf6e50994e12f1135748a51bf6380dc04bd5f4907 (patch)
treededf4fac8c4810fd4f3127c458737e364dc1bbc6 /src/egl/main/Makefile.am
parent7a109268ab5b3544e7f7b99e84ef1fdf54023fb4 (diff)
Import eglextchromium.h from Chromium.
In order to support the (currently unregistered) Chromium-specific EGL extension eglGetSyncValuesCHROMIUM on Intel systems, we need to import the Chromium header that defines it. The file was downloaded from https://chromium.googlesource.com/chromium/chromium/+/trunk/ui/gl/EGL/eglextchromium.h It is subject to the license found at https://chromium.googlesource.com/chromium/chromium/+/trunk/LICENSE I have imported the header file and added the license text to the top. The only change was to fix the include guard on the Chromium header to change the last line from a #define to a #endif, which makes the header actually compile. Signed-off-by: Sarah Sharp <[email protected]> Reviewed-by: Chad Versace <[email protected]> Cc: Jamey Sharp <[email protected]> Cc: Ian Romanick <[email protected]> Cc: Stéphane Marchesin <[email protected]>
Diffstat (limited to 'src/egl/main/Makefile.am')
-rw-r--r--src/egl/main/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/egl/main/Makefile.am b/src/egl/main/Makefile.am
index 2858913eae8..23207db8ae1 100644
--- a/src/egl/main/Makefile.am
+++ b/src/egl/main/Makefile.am
@@ -126,5 +126,6 @@ egldir = $(includedir)/EGL
egl_HEADERS = \
$(top_srcdir)/include/EGL/eglext.h \
$(top_srcdir)/include/EGL/egl.h \
+ $(top_srcdir)/include/EGL/eglextchromium.h \
$(top_srcdir)/include/EGL/eglmesaext.h \
$(top_srcdir)/include/EGL/eglplatform.h