summaryrefslogtreecommitdiffstats
path: root/src/egl/main/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <[email protected]>2014-01-07 12:08:30 -0800
committerChad Versace <[email protected]>2014-02-05 18:19:26 -0800
commit1340e24406fbdfdbfb49dc19d7d5d72d6e363631 (patch)
tree09545176bdfa21dcf9a4ce9a548ea92328d8b465 /src/egl/main/Makefile.am
parent0224bd20f391e8e26637380bb50187ba2fb51ee4 (diff)
egl/glx: Remove egl_glx driver
Mesa now has a real, feature-rich EGL implementation on X11 via xcb. Therefore I believe there is no longer a practical need for the egl_glx driver. Furthermore, egl_glx appears to be unmaintained. The most recent nontrivial commit to egl_glx was 6baa5f1 on 2011-11-25. Tested by running weston-smoke in windowed Weston on X with i965. Signed-off-by: Chad Versace <[email protected]> Acked-by: Kenneth Graunke <[email protected]> Acked-by: Kristian Høgsberg <[email protected]>
Diffstat (limited to 'src/egl/main/Makefile.am')
-rw-r--r--src/egl/main/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/egl/main/Makefile.am b/src/egl/main/Makefile.am
index 4c20d1215ee..46e890a99f6 100644
--- a/src/egl/main/Makefile.am
+++ b/src/egl/main/Makefile.am
@@ -102,12 +102,6 @@ if HAVE_EGL_PLATFORM_NULL
AM_CFLAGS += -DHAVE_NULL_PLATFORM
endif
-if HAVE_EGL_DRIVER_GLX
-AM_CFLAGS += -D_EGL_BUILT_IN_DRIVER_GLX
-libEGL_la_LIBADD += ../drivers/glx/libegl_glx.la
-libEGL_la_LIBADD += $(DLOPEN_LIBS)
-endif
-
if HAVE_EGL_DRIVER_DRI2
AM_CFLAGS += -D_EGL_BUILT_IN_DRIVER_DRI2
AM_CFLAGS += -DHAVE_XCB_DRI2