summaryrefslogtreecommitdiffstats
path: root/src/egl/drivers/dri2/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-07-14 01:52:51 +0100
committerEmil Velikov <[email protected]>2015-07-22 16:35:26 +0100
commit78674631a2d0ff1eb538470e2a1d516201361f03 (patch)
tree92dccdeb471206f7eaea65b1f33532686ece9e69 /src/egl/drivers/dri2/Makefile.am
parentce2a4bd541241dade00a36e9f2d8e5ca16c6ff03 (diff)
egl: remove the non-haiku scons build
It has been broken since 2011 with commit c98ea26e16b(egl: Make egl_dri2 and egl_glx built-in drivers.). When the backends got merged into the main library each entry point was guarded by a _EGL_BUILT_IN_DRIVER_* define. As the define was missing, the linker kindly removed the whole of the dri2 backend, thus we did not notice any errors due to the unresolved link to xcb and friends. Cc: Chia-I Wu <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Acked-by: Matt Turner <[email protected]> Reviewed-by: Jose Fonseca <[email protected]>
Diffstat (limited to 'src/egl/drivers/dri2/Makefile.am')
-rw-r--r--src/egl/drivers/dri2/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/egl/drivers/dri2/Makefile.am b/src/egl/drivers/dri2/Makefile.am
index 55be4a75ba5..f4649de18df 100644
--- a/src/egl/drivers/dri2/Makefile.am
+++ b/src/egl/drivers/dri2/Makefile.am
@@ -69,5 +69,3 @@ if HAVE_EGL_PLATFORM_SURFACELESS
libegl_dri2_la_SOURCES += platform_surfaceless.c
AM_CFLAGS += -DHAVE_SURFACELESS_PLATFORM
endif
-
-EXTRA_DIST = SConscript