summaryrefslogtreecommitdiffstats
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Gordon <[email protected]>2018-06-13 16:17:32 -0600
committerGurchetan Singh <[email protected]>2019-03-21 10:18:31 -0700
commitb30aad552cde507a70c6bf3bc2ce40ed69e0ecf2 (patch)
treea3b516755365b867863253b75accecc4fdae8899 /src/egl/Makefile.am
parente426c3a6cb020d1b156415e20c6f53a7195f96cd (diff)
configure.ac/meson.build: Add options for library suffixes
When building the Chrome OS Android container, we need to build copies of mesa that don't conflict with the Android system-supplied libraries. This adds options to create suffixed versions of EGL and GLES libraries: libEGL.so -> libEGL${egl-lib-suffix}.so libGLESv1_CM.so -> libGLESv1_CM${gles-lib-suffix}.so libGLESv2.so -> libGLES${gles-lib-suffix}.so This is similar to what happens when --enable-libglvnd is specified, but without the side effects of linking against libglvnd. To avoid unexpected clashes with the suffixed appended by libglvnd, make it an error to specify both --enable-libglvnd and --with-egl-lib-suffix. Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index 4383cca1e00..349779feb4e 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -190,12 +190,12 @@ libEGL_mesa_la_LDFLAGS = \
else # USE_LIBGLVND
-lib_LTLIBRARIES = libEGL.la
-libEGL_la_SOURCES =
-libEGL_la_LIBADD = \
+lib_LTLIBRARIES = libEGL@[email protected]
+libEGL@EGL_LIB_SUFFIX@_la_SOURCES =
+libEGL@EGL_LIB_SUFFIX@_la_LIBADD = \
libEGL_common.la \
$(top_builddir)/src/mapi/shared-glapi/libglapi.la
-libEGL_la_LDFLAGS = \
+libEGL@EGL_LIB_SUFFIX@_la_LDFLAGS = \
-no-undefined \
-version-number 1:0 \
$(BSYMBOLIC) \