summaryrefslogtreecommitdiffstats
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-08-24 11:14:15 +0100
committerEmil Velikov <[email protected]>2018-08-24 11:14:15 +0100
commitcff80b6c153661ed40a207815a3d3a132daae656 (patch)
tree9942a8361e0d4d7662af8e782c21388a725880b1 /src/egl/Makefile.am
parent7a4d2d1fdf3fd6dd79cda971b5b3669fc7fbc729 (diff)
Revert "configure: allow building with python3"
This reverts commit ae7898dfdbe5c8dab7d11c71862353f1ae43feb0. Turns out the python scripts are _not_ fully python 3 compatible. As Ilia reported using get_xmlpool.py with LANG=C produces some weird output - see the link for details. Even though the issue was spotted with the autoconf build, it exposes a genuine problem with the script (and lack of lang handling of the meson build.) https://lists.freedesktop.org/archives/mesa-dev/2018-August/203508.html
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index 24a8e96a8e1..bf7f87015b7 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -141,7 +141,7 @@ GLVND_GEN_DEPS = generate/gen_egl_dispatch.py \
generate/egl.xml generate/eglFunctionList.py generate/genCommon.py \
generate/egl_other.xml
-PYTHON_GEN = $(AM_V_GEN)$(PYTHON) $(PYTHON_FLAGS)
+PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
g_egldispatchstubs.c: $(GLVND_GEN_DEPS)
$(PYTHON_GEN) $(top_srcdir)/src/egl/generate/gen_egl_dispatch.py source \
$(top_srcdir)/src/egl/generate/eglFunctionList.py \