summaryrefslogtreecommitdiffstats
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-09-08 11:52:01 +0100
committerEric Engestrom <[email protected]>2017-09-12 13:53:11 +0100
commit5c68ea29f31283768c8e1b631eb812d1e74cb5c3 (patch)
treef37325b713cf841ac49ea6e0cb372b5619473d1d /src/egl/Makefile.am
parentf4a9d205d8a6474defa86dc4f12b7e63e61a49d9 (diff)
egl+glx: turn LIBGL_ALWAYS_SOFTWARE into a boolean
Instead of setting based on set/unset, allow users to use boolean values. In the docs, use `ALWAYS=true` instead of `ALWAYS=1` as it's clearer IMO. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index bb8ec9745dd..8ff1ffaba18 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -45,6 +45,7 @@ libEGL_common_la_SOURCES = \
$(LIBEGL_C_FILES)
libEGL_common_la_LIBADD = \
+ $(top_builddir)/src/util/libmesautil.la \
$(EGL_LIB_DEPS)
dri2_backend_FILES =
@@ -82,7 +83,6 @@ AM_CFLAGS += $(WAYLAND_CFLAGS)
libEGL_common_la_LIBADD += $(WAYLAND_LIBS)
libEGL_common_la_LIBADD += $(LIBDRM_LIBS)
libEGL_common_la_LIBADD += $(top_builddir)/src/egl/wayland/wayland-drm/libwayland-drm.la
-libEGL_common_la_LIBADD += $(top_builddir)/src/util/libmesautil.la
dri2_backend_FILES += \
drivers/dri2/platform_wayland.c \
drivers/dri2/linux-dmabuf-unstable-v1-protocol.c \