summaryrefslogtreecommitdiffstats
path: root/src/drm-shim/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-07-22 14:50:15 +0100
committerEric Engestrom <[email protected]>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/drm-shim/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Eric Anholt <[email protected]> Tested-by: Vinson Lee <[email protected]>
Diffstat (limited to 'src/drm-shim/meson.build')
-rw-r--r--src/drm-shim/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/drm-shim/meson.build b/src/drm-shim/meson.build
index 1638c5ae728..ab05f9af035 100644
--- a/src/drm-shim/meson.build
+++ b/src/drm-shim/meson.build
@@ -24,9 +24,8 @@ drm_shim = static_library(
'device.c',
'drm_shim.c',
],
- link_with: libmesa_util,
include_directories: [inc_common],
- dependencies: [dep_dl],
+ dependencies: [idep_mesautil, dep_dl],
c_args : [c_vis_args, '-std=gnu99'],
)
dep_drm_shim = declare_dependency(