summaryrefslogtreecommitdiffstats
path: root/src/compiler/spirv/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <[email protected]>2018-08-09 10:27:26 +0200
committerDylan Baker <[email protected]>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /src/compiler/spirv/meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/compiler/spirv/meson.build')
-rw-r--r--src/compiler/spirv/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/compiler/spirv/meson.build b/src/compiler/spirv/meson.build
index eb0c0d554d9..c91d12a27d9 100644
--- a/src/compiler/spirv/meson.build
+++ b/src/compiler/spirv/meson.build
@@ -22,12 +22,12 @@ vtn_gather_types_c = custom_target(
'vtn_gather_types.c',
input : files('vtn_gather_types_c.py', 'spirv.core.grammar.json'),
output : 'vtn_gather_types.c',
- command : [prog_python2, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
+ command : [prog_python, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
)
spirv_info_c = custom_target(
'spirv_info.c',
input : files('spirv_info_c.py', 'spirv.core.grammar.json'),
output : 'spirv_info.c',
- command : [prog_python2, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
+ command : [prog_python, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
)