summaryrefslogtreecommitdiffstats
path: root/src/compiler/spirv/meson.build
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2017-08-14 10:40:09 -0700
committerIan Romanick <[email protected]>2018-03-29 14:16:01 -0700
commit042ee4bea26272bd7c358cc9541e576a8352890c (patch)
treed03707e886103019722ee20ba86cdf57c67b7097 /src/compiler/spirv/meson.build
parent2c9621ee5c5fa40be071858f99fb256fc37369b4 (diff)
spirv: Move SPIR-V building to Makefile.spirv.am and spirv/meson.build
Future changes will add generated files used only from src/compiler/glsl. These can't be built from Makefile.nir.am, and we can't move all the rules from Makefile.nir.am to Makefile.spirv.am (and it would be silly anyway). v2: Do it for meson too. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (the meson bits) Reviewed-by: Alejandro Piñeiro <[email protected]> (the automake bits)
Diffstat (limited to 'src/compiler/spirv/meson.build')
-rw-r--r--src/compiler/spirv/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/compiler/spirv/meson.build b/src/compiler/spirv/meson.build
new file mode 100644
index 00000000000..eb0c0d554d9
--- /dev/null
+++ b/src/compiler/spirv/meson.build
@@ -0,0 +1,33 @@
+# Copyright © 2017 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+vtn_gather_types_c = custom_target(
+ 'vtn_gather_types.c',
+ input : files('vtn_gather_types_c.py', 'spirv.core.grammar.json'),
+ output : 'vtn_gather_types.c',
+ command : [prog_python2, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
+)
+
+spirv_info_c = custom_target(
+ 'spirv_info.c',
+ input : files('spirv_info_c.py', 'spirv.core.grammar.json'),
+ output : 'spirv_info.c',
+ command : [prog_python2, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
+)