aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorSamuel Pitoiset <[email protected]>2018-01-29 17:19:00 +0100
committerSamuel Pitoiset <[email protected]>2018-02-06 23:08:39 +0100
commite68562b94b79f5ce17f5804f8d7308faf57bd3f0 (patch)
treeb3900a4674aa485ed0605c3ab96093149f2ba5f0 /src/compiler/nir/meson.build
parente2ea9e11910a10ae10d6491d913ab1d57f97a0d4 (diff)
nir: add nir_opt_shrink_load pass
This is a very simple pass that just shrinks load_push_constant intrinsics when some components are unused. For now, it can just shrink vec4 to vec3, vec3 to vec2 and so on. Signed-off-by: Samuel Pitoiset <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index b5f27ad667b..859a0c1e62d 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -162,6 +162,7 @@ files_libnir = files(
'nir_opt_move_comparisons.c',
'nir_opt_peephole_select.c',
'nir_opt_remove_phis.c',
+ 'nir_opt_shrink_load.c',
'nir_opt_trivial_continues.c',
'nir_opt_undef.c',
'nir_phi_builder.c',