aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorIago Toral Quiroga <[email protected]>2018-04-26 10:02:04 +0200
committerIago Toral Quiroga <[email protected]>2018-05-03 11:40:25 +0200
commitb9a3d8c23e53b261ec626c13f0f0f6858f919371 (patch)
tree772ce6198afd1af0ac14cc7c642cd6e4b4f427f0 /src/compiler/nir/meson.build
parentf575277f7e4cd3568ae2b0d8d2b0c6e0cf611d62 (diff)
compiler/nir: add a lowering pass to convert the bit size of ALU operations
Not all bit-sizes may be supported natively in hardware for all operations. This pass allows drivers to lower such operations to a bit-size that is actually supported and then converts the result back to the original bit-size. Compiler backends control which operations and wich bit-sizes require the lowering through a callback function. v2: generalize this pass and make it available in NIR core (Rob, Jason) v3: remove some temporaries and reduce nesting in instruction loop using a continue statement (Jason) Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 4fffbb7a1ee..57bf90c58b1 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -141,6 +141,7 @@ files_libnir = files(
'nir_lower_vec_to_movs.c',
'nir_lower_wpos_center.c',
'nir_lower_wpos_ytransform.c',
+ 'nir_lower_bit_size.c',
'nir_metadata.c',
'nir_move_vec_src_uses_to_dest.c',
'nir_normalize_cubemap_coords.c',