aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-30 20:48:32 -0700
committerDylan Baker <[email protected]>2017-10-03 10:02:08 -0700
commit7a5a986ddd88487a42847f00f46f7bb0a542c988 (patch)
tree6e58782eac3b11dadf6287e68c93eb0286671d0c /src/compiler/nir/meson.build
parent052c0d5edacf377a4b36cc9fee2945f8a9b38787 (diff)
meson: convert gtest to an internal dependency
In truth gtest is an external dependency that upstream expects you to "vendor" into your own tree. As such, it makes sense to treat it more like a dependency than an internal library, and collect it's requirements together in a dependency object. v2: - include with -isystem instead of setting compiler args (Eric) Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index c260dca5467..8a85d119530 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -197,8 +197,8 @@ if with_tests
[files('tests/control_flow_tests.cpp'), nir_opcodes_h],
c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
include_directories : [inc_common],
- dependencies : [dep_thread],
- link_with : [libmesa_util, libnir, libgtest],
+ dependencies : [dep_thread, idep_gtest],
+ link_with : [libmesa_util, libnir],
)
test('nir_control_flow', nir_control_flow_test)