aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2018-03-21 16:48:35 -0700
committerJason Ekstrand <[email protected]>2018-06-22 20:15:57 -0700
commit39bf61aa37b0336aa27d8e3d2bf64587f07ff477 (patch)
tree71862af4a722fd8a2ef95aa5de09820fc0e7e411 /src/compiler/nir/meson.build
parenteb40540b8aa30279b80fa3a879e20bbb5d16838f (diff)
nir: Add a concept of per-member structs and a lowering pass
This adds a concept of "members" to a variable with an interface type. It allows you to specify the full variable data for each member of the interface instead of once for the variable. We also add a lowering pass to lower those variables to a sequence of variables and rewrite all the derefs accordingly. Acked-by: Rob Clark <[email protected]> Acked-by: Bas Nieuwenhuizen <[email protected]> Acked-by: Dave Airlie <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 9d50782513e..d5df696a4a8 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -180,6 +180,7 @@ files_libnir = files(
'nir_search_helpers.h',
'nir_serialize.c',
'nir_serialize.h',
+ 'nir_split_per_member_structs.c',
'nir_split_var_copies.c',
'nir_sweep.c',
'nir_to_lcssa.c',