aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2018-07-24 10:08:06 -0700
committerJason Ekstrand <[email protected]>2018-08-23 21:44:14 -0500
commit26eb077ec486d0daf5a72d20bb5c03509592dce4 (patch)
tree11d528a32dae3e8e2a9c6e154aa30c94a7c416bf /src/compiler/nir/meson.build
parentb489998e63f5bd773344c8185d2e9817936116c9 (diff)
nir: Add a structure splitting pass
This pass doesn't really do much now because nir_lower_vars_to_ssa can already see through structures and considers them to be "split". This pass exists to help other passes more easily see through structure variables. If a back-end does implement arrays using scratch or indirects on registers, having more smaller arrays is likely to have better memory efficiency. Reviewed-by: Caio Marcelo de Oliveira Filho <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 8708f9b069c..b32ae75f76b 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -184,6 +184,7 @@ files_libnir = files(
'nir_serialize.h',
'nir_split_per_member_structs.c',
'nir_split_var_copies.c',
+ 'nir_split_vars.c',
'nir_sweep.c',
'nir_to_lcssa.c',
'nir_validate.c',