summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorDaniel Schürmann <[email protected]>2019-05-20 14:58:23 +0200
committerDaniel Schürmann <[email protected]>2019-08-20 17:40:13 +0200
commitdf86c5ffb35700466cdafc6a87b8a0279e473d07 (patch)
treee197972bdf4a9d9009cd782b4ac66a98540ff94a /src/compiler/nir/meson.build
parent7b07034931440e87f8ba0475354bb66a30d2ccde (diff)
nir: add divergence analysis pass.
This pass expects the shader to be in LCSSA form. The algorithm is based on 'The Simple Divergence Analysis' from Diogo Sampaio, Rafael De Souza, Sylvain Collange, Fernando Magno Quintão Pereira. Divergence Analysis. ACM Transactions on Programming Languages and Systems (TOPLAS) Reviewed-by: Jason Ekstrand <[email protected]> Reviewed-by: Connor Abbott <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 541cc00df9d..04e4f729902 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -96,6 +96,7 @@ files_libnir = files(
'nir_control_flow_private.h',
'nir_deref.c',
'nir_deref.h',
+ 'nir_divergence_analysis.c',
'nir_dominance.c',
'nir_format_convert.h',
'nir_from_ssa.c',