summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorTimur Kristóf <[email protected]>2019-02-08 22:36:37 +0100
committerEric Anholt <[email protected]>2019-03-05 19:13:27 +0000
commit909d1f50f3ffc62d5a23669ad0bc8eedb9416af0 (patch)
treec027bc73c8997ba44e7c83817f7863a5838339d9 /src/compiler/nir/meson.build
parent4dba72c4b35eeb312da232b2f30f067885bc9f07 (diff)
nir: Move nir_lower_uniforms_to_ubo to compiler/nir.
The nir_lower_uniforms_to_ubo function is useful outside of mesa/state_tracker, and in fact is needed to produce NIR for drivers that have the PIPE_CAP_PACKED_UNIFORMS capability. Signed-Off-By: Timur Kristóf <[email protected]> Tested-by: Andre Heider <[email protected]> Tested-by: Rob Clark <[email protected]> Reviewed-by: Timothy Arceri <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 20a26a26255..d7f88f391f4 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -150,6 +150,7 @@ files_libnir = files(
'nir_lower_wpos_center.c',
'nir_lower_wpos_ytransform.c',
'nir_lower_bit_size.c',
+ 'nir_lower_uniforms_to_ubo.c',
'nir_metadata.c',
'nir_move_load_const.c',
'nir_move_vec_src_uses_to_dest.c',