summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2019-09-27 10:15:02 -0700
committerRob Clark <[email protected]>2019-10-18 15:08:54 -0700
commit5e08f070f0fc99246fa8aab027feeee33b774177 (patch)
tree973a6e49abedd052345cc0690bf3e70219779b72 /src/compiler/nir/meson.build
parent1bdde313926b698d9959294f1563264ead532b46 (diff)
nir: add nir_lower_amul pass
Lower amul to either imul or imul24, depending on whether 24b is enough bits to calculate an offset within the thing being dereferenced. Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index a485f82cf0f..56bab469b78 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -114,6 +114,7 @@ files_libnir = files(
'nir_lower_alu.c',
'nir_lower_alu_to_scalar.c',
'nir_lower_alpha_test.c',
+ 'nir_lower_amul.c',
'nir_lower_array_deref_of_vec.c',
'nir_lower_atomics_to_ssbo.c',
'nir_lower_bitmap.c',