summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorKarol Herbst <[email protected]>2019-12-02 22:41:33 +0100
committerKarol Herbst <[email protected]>2019-12-11 13:00:44 +0100
commit11f736a6f9c516af9405ffac0795af4cbebaa295 (patch)
treee76d1682636c8ce5e76e37c7b59eb71d3b7d9e1f /src/compiler/nir/meson.build
parent676232d76fdce1421d4294ac578daa717d976a2f (diff)
nir/tests: add serializer tests
Signed-off-by: Karol Herbst <[email protected]> Reviewed-by: Connor Abbott <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index a5a3e90c8a4..43a91769253 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -349,4 +349,16 @@ if with_tests
),
suite : ['compiler', 'nir'],
)
+
+ test(
+ 'nir_serialize_test',
+ executable(
+ 'nir_serialize_test',
+ files('tests/serialize_tests.cpp'),
+ cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+ include_directories : [inc_common],
+ dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
+ ),
+ suite : ['compiler', 'nir'],
+ )
endif