summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorJonathan Marek <[email protected]>2019-05-08 10:26:49 -0400
committerJonathan Marek <[email protected]>2019-07-24 17:36:21 -0400
commitbc3b6168bac39a16326c730a9d0ae97b45c7df23 (patch)
tree58816c0efaa72880f75d457c725ff8b417ecf188 /src/compiler/nir/meson.build
parent5a4e71c082886810504ecfa329fb57050acc623f (diff)
nir: replace lower_sincos with algebraic opt
This version has less ops for the same precision. Signed-off-by: Jonathan Marek <[email protected]> Reviewed-by: Vasily Khoruzhick <[email protected]> Acked-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 169c31aacd5..a54e899912f 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -152,7 +152,6 @@ files_libnir = files(
'nir_lower_returns.c',
'nir_lower_scratch.c',
'nir_lower_subgroups.c',
- 'nir_lower_sincos.c',
'nir_lower_system_values.c',
'nir_lower_tex.c',
'nir_lower_to_source_mods.c',
@@ -270,7 +269,7 @@ if with_tests
include_directories : [inc_common],
dependencies : [dep_thread, idep_gtest, idep_nir],
link_with : libmesa_util,
- ),
+ ),
suite : ['compiler', 'nir'],
)