summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorIago Toral Quiroga <[email protected]>2019-07-31 09:47:08 +0200
committerIago Toral Quiroga <[email protected]>2019-08-13 09:44:12 +0200
commit48f5c34301e9f03a18b928251180c82b8c7571d1 (patch)
tree4f2b2381711609d9207e509765ca8b9def83ebe2 /src/compiler/nir/meson.build
parent62e0ca3064ba2500f97025599d5ca7210cb4dc04 (diff)
nir: add a pass to clamp gl_PointSize to a range
The OpenGL and OpenGL ES specs require that implementations clamp the value of gl_PointSize to an implementation-depedent range. This pass is useful for any GPU hardware that doesn't do this automatically for either one or both sides of the range, such as V3D. v2: - Turn into a generic NIR pass (Eric). - Make the pass work before lower I/O so we can use the deref variable to inspect if we are writing to gl_PointSize (Eric). - Make the pass take the range to clamp as parameter and allow it to clamp to both sides of the range or just one side. - Make the pass report progress. v3: - Fix copyright header (Eric) - use fmin/fmax instead of bcsel to clamp (Eric) Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 9b527b22f7c..336bf2ef543 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -148,6 +148,7 @@ files_libnir = files(
'nir_lower_passthrough_edgeflags.c',
'nir_lower_patch_vertices.c',
'nir_lower_phis_to_scalar.c',
+ 'nir_lower_point_size.c',
'nir_lower_regs_to_ssa.c',
'nir_lower_returns.c',
'nir_lower_scratch.c',