summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2017-08-22 13:23:59 -0700
committerJason Ekstrand <[email protected]>2017-11-07 10:37:52 -0800
commit28da82f9783091cb3e79586962f98a5bc165cff8 (patch)
tree17ab49d93f9d1264993a8d38662c62537b3010dd /src/compiler/nir/meson.build
parent1ca3a9442760b6f7ffcc624bdc527fc7dbc70825 (diff)
nir: Add a new subgroups lowering pass
This commit pulls nir_lower_read_invocations_to_scalar along with most of the guts of nir_opt_intrinsics (which mostly does subgroup lowering) into a new nir_lower_subgroups pass. There are various other bits of subgroup lowering that we're going to want to do so it makes a bit more sense to keep it all together in one pass. We also move it in i965 to happen after nir_lower_system_values to ensure that because we want to handle the subgroup mask system value intrinsics here. Reviewed-by: Iago Toral Quiroga <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index bb9ac084480..e5c8326aa06 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -120,11 +120,11 @@ files_libnir = files(
'nir_lower_passthrough_edgeflags.c',
'nir_lower_patch_vertices.c',
'nir_lower_phis_to_scalar.c',
- 'nir_lower_read_invocation_to_scalar.c',
'nir_lower_regs_to_ssa.c',
'nir_lower_returns.c',
'nir_lower_samplers.c',
'nir_lower_samplers_as_deref.c',
+ 'nir_lower_subgroups.c',
'nir_lower_system_values.c',
'nir_lower_tex.c',
'nir_lower_to_source_mods.c',