summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2016-12-02 11:36:42 -0800
committerEric Anholt <[email protected]>2019-04-12 15:59:31 -0700
commit18ed82b084c79bf63666f2da22e5d675fb01aa26 (patch)
treedfb02920970472c7158b2bba889ad05a8ab10c0e /src/compiler/nir/meson.build
parent8a2d91e1248e31426ff656c02d3e598f9e117422 (diff)
nir: Add a pass for selectively lowering variables to scratch space
This commit adds new nir_load/store_scratch opcodes which read and write a virtual scratch space. It's up to the back-end to figure out what to do with it and where to put the actual scratch data. v2: Drop const_index comments (by anholt) Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 54655f7cd7c..4e5039e28e0 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -143,6 +143,7 @@ files_libnir = files(
'nir_lower_phis_to_scalar.c',
'nir_lower_regs_to_ssa.c',
'nir_lower_returns.c',
+ 'nir_lower_scratch.c',
'nir_lower_subgroups.c',
'nir_lower_system_values.c',
'nir_lower_tex.c',