summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorTimothy Arceri <[email protected]>2018-04-30 20:39:43 +1000
committerTimothy Arceri <[email protected]>2018-05-01 12:39:33 +1000
commit6487e7a30c9e4c2a417ddfe632d5f68e065e21eb (patch)
tree561df9b47ea4efa99c89dd80dfd22a1a1e122ae8 /src/compiler/nir/meson.build
parentf56e22e49673e8234a7fe0c241b4c3eae4752f34 (diff)
nir: move GL specific passes to src/compiler/glsl
With this we should have no passes in src/compiler/nir with any dependencies on headers from core GL Mesa. Reviewed-by: Alejandro PiƱeiro <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index b28a565d0c6..84715a58912 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -106,7 +106,6 @@ files_libnir = files(
'nir_lower_64bit_packing.c',
'nir_lower_alu_to_scalar.c',
'nir_lower_alpha_test.c',
- 'nir_lower_atomics.c',
'nir_lower_atomics_to_ssbo.c',
'nir_lower_bitmap.c',
'nir_lower_clamp_color_outputs.c',
@@ -132,8 +131,6 @@ files_libnir = files(
'nir_lower_phis_to_scalar.c',
'nir_lower_regs_to_ssa.c',
'nir_lower_returns.c',
- 'nir_lower_samplers.c',
- 'nir_lower_samplers_as_deref.c',
'nir_lower_subgroups.c',
'nir_lower_system_values.c',
'nir_lower_tex.c',