summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2019-06-17 16:27:37 -0700
committerIan Romanick <[email protected]>2019-07-08 11:30:10 -0700
commitb08d7040518cdf76792952ceef72cadaa54d0179 (patch)
tree25981a79e6ae7448d6f5f103f08e136da7354dcf /src/compiler/nir/meson.build
parentf734e2a042e3cee94fb8200e8baf34a81c5de46e (diff)
nir: Add unit tests for nir_opt_comparison_pre
Each tests has a comment with the expected before and after NIR. The tests don't actually check this. The tests only check whether or not the optimization pass reported progress. I couldn't think of a robust, future-proof way to check the before and after code. Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 01ddcdf0ea0..169c31aacd5 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -306,4 +306,16 @@ if with_tests
link_with : libmesa_util,
)
)
+
+ test(
+ 'comparison_pre',
+ executable(
+ 'comparison_pre',
+ files('tests/comparison_pre_tests.cpp'),
+ c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+ include_directories : [inc_common],
+ dependencies : [dep_thread, idep_gtest, idep_nir],
+ link_with : libmesa_util,
+ )
+ )
endif