summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorConnor Abbott <[email protected]>2018-11-29 17:46:59 +0100
committerConnor Abbott <[email protected]>2018-12-05 17:57:40 +0100
commita0ae12ca91a45f81897e774019cde9bd081f03a0 (patch)
tree87deeaf0a95807d28ed3b1f2e6075969d3a93c87 /src/compiler/nir/meson.build
parent29a1450e288c57727a5cfe22fa4463a53f9cc8bf (diff)
nir/algebraic: Add unit tests for bitsize validation
The non-failure path can be tested by just compiling mesa and then testing it, but the failure paths won't be hit unless you make a mistake, so it's best to test them with some unit tests. Reviewed-by: Jason Ekstrand <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 61f61f0a34b..e86c97b8864 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -262,4 +262,11 @@ if with_tests
),
suite : ['compiler', 'nir'],
)
+ test(
+ 'nir_algebraic_parser',
+ prog_python,
+ args : [
+ join_paths(meson.current_source_dir(), 'tests/algebraic_parser_test.py')
+ ],
+ )
endif