summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-12-11 16:13:31 -0800
committerDylan Baker <[email protected]>2018-01-11 15:40:02 -0800
commit4ccb9816737945159289527322e759d92bf7a4d6 (patch)
tree5f4cc22fa3d962cfde826599e5a95e26904bdc8d /src/compiler/nir/meson.build
parent8e981eb2b7099849c7b74d855afb0c65f92227e8 (diff)
meson: Use consistent style for tests
Don't use intermediate variables, use consistent whitespace. Acked-by: Eric Engestrom <[email protected]> Signed-off-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 5dd21e6652f..54cef67e9e0 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -208,14 +208,15 @@ libnir = static_library(
nir_algebraic_py = files('nir_algebraic.py')
if with_tests
- nir_control_flow_test = executable(
- 'nir_control_flow_test',
- [files('tests/control_flow_tests.cpp'), nir_opcodes_h],
- c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
- include_directories : [inc_common],
- dependencies : [dep_thread, idep_gtest],
- link_with : [libmesa_util, libnir],
+ test(
+ 'nir_control_flow',
+ executable(
+ 'nir_control_flow_test',
+ [files('tests/control_flow_tests.cpp'), nir_opcodes_h],
+ c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+ include_directories : [inc_common],
+ dependencies : [dep_thread, idep_gtest],
+ link_with : [libmesa_util, libnir],
+ )
)
-
- test('nir_control_flow', nir_control_flow_test)
endif