summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2018-10-18 12:04:09 -0500
committerJason Ekstrand <[email protected]>2018-12-16 21:03:02 +0000
commit11dc1307794e811aa8cfa5c9dace713d82db09ec (patch)
tree88595d35198b3a5bc2e3c4e63c07cd68390281c6 /src/compiler/nir/meson.build
parent191a1dce92803a99dae774b47264ff32da7b6689 (diff)
nir: Add a bool to int32 lowering pass
We also enable it in all of the NIR drivers. Reviewed-by: Eric Anholt <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]> Tested-by: Bas Nieuwenhuizen <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 5eb1df2a68f..e252f64539e 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -114,6 +114,7 @@ files_libnir = files(
'nir_lower_alpha_test.c',
'nir_lower_atomics_to_ssbo.c',
'nir_lower_bitmap.c',
+ 'nir_lower_bool_to_int32.c',
'nir_lower_clamp_color_outputs.c',
'nir_lower_clip.c',
'nir_lower_clip_cull_distance_arrays.c',