aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorMike Blumenkrantz <[email protected]>2020-06-17 09:35:46 -0400
committerMarge Bot <[email protected]>2020-07-03 08:56:30 +0000
commitfb2fe802f638d7a70f0d00ec1d496f317d241765 (patch)
tree048838ee2da74fb3a9ff9d3f40e0b342cbc49c57 /src/compiler/nir/meson.build
parentf8946bd705ce8cfaf0d2d571fefcf67161f9c5d5 (diff)
nir: add lowering pass for clip plane enabling
a pass which rewrites gl_ClipDistance[n] to an undef if the corresponding clip plane is disabled in the rasterizer state this pass is needed for zink to handle api disables of clip planes Reviewed-by: Erik Faye-Lund <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/5529>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 20260d0d5e6..2ca803563d6 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -125,6 +125,7 @@ files_libnir = files(
'nir_lower_clamp_color_outputs.c',
'nir_lower_clip.c',
'nir_lower_clip_cull_distance_arrays.c',
+ 'nir_lower_clip_disable.c',
'nir_lower_clip_halfz.c',
'nir_lower_variable_initializers.c',
'nir_lower_discard_to_demote.c',