aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2018-05-24 11:37:51 -0700
committerIan Romanick <[email protected]>2019-03-28 15:35:52 -0700
commitbe1cc3552bc8af23612e37521bc90d106610e62e (patch)
tree063b6bb10d4173d96865eb4f83816d8fd3690c72 /src/compiler/nir/meson.build
parentae21b52e1dc5db5f7678ce9817364384dc0cbc87 (diff)
nir: Add nir_const_value_negative_equal
v2: Rebase on 1-bit Boolean changes. Reviewed-by: Thomas Helland <[email protected]> [v1] Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index eecc19e7a6e..0900f56648e 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -282,4 +282,16 @@ if with_tests
],
suite : ['compiler', 'nir'],
)
+
+ test(
+ 'negative_equal',
+ executable(
+ 'negative_equal',
+ files('tests/negative_equal_tests.cpp'),
+ c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+ include_directories : [inc_common],
+ dependencies : [dep_thread, idep_gtest, idep_nir],
+ link_with : libmesa_util,
+ )
+ )
endif