summaryrefslogtreecommitdiffstats
path: root/src/compiler/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-04-16 14:40:51 -0700
committerDylan Baker <[email protected]>2018-04-24 14:08:15 -0700
commit595021bf1a67346c7dfca652ef2dbcce3e2a6ca0 (patch)
tree5e5f7b11473e99e1714690d398b8d417a6a05538 /src/compiler/meson.build
parentdb90c8627c41486056aeef9883ef0e4a5f245441 (diff)
meson: remove dummy_cpp
meson has gotten pretty smart about tracking C and C++ dependencies (internal and external), and using the right linker. This wasn't always the case and we created empty c++ files to force the use of the c++ linker. We don't need that any more. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/compiler/meson.build')
-rw-r--r--src/compiler/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/compiler/meson.build b/src/compiler/meson.build
index da2464d7b8c..60b633832d4 100644
--- a/src/compiler/meson.build
+++ b/src/compiler/meson.build
@@ -62,7 +62,7 @@ subdir('nir')
# dependency with nir/meson.build.
spirv2nir = executable(
'spirv2nir',
- [files('spirv/spirv2nir.c'), dummy_cpp],
+ files('spirv/spirv2nir.c'),
dependencies : [dep_m, dep_thread, idep_nir],
include_directories : [inc_common, inc_nir, include_directories('spirv')],
link_with : libmesa_util,