summaryrefslogtreecommitdiffstats
path: root/src/compiler/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <[email protected]>2018-08-09 10:27:26 +0200
committerDylan Baker <[email protected]>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /src/compiler/meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/compiler/meson.build')
-rw-r--r--src/compiler/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/compiler/meson.build b/src/compiler/meson.build
index 60b633832d4..0f8f3c12966 100644
--- a/src/compiler/meson.build
+++ b/src/compiler/meson.build
@@ -40,7 +40,7 @@ ir_expression_operation_h = custom_target(
'ir_expression_operation.h',
input : 'glsl/ir_expression_operation.py',
output : 'ir_expression_operation.h',
- command : [prog_python2, '@INPUT@', 'enum'],
+ command : [prog_python, '@INPUT@', 'enum'],
capture : true,
)