summaryrefslogtreecommitdiffstats
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
authorEduardo Lima Mitev <[email protected]>2017-11-15 00:29:28 +0100
committerAlejandro Piñeiro <[email protected]>2018-06-21 14:25:05 +0200
commit3cf12c63175298a806d6fc7b20db9fe2e8059397 (patch)
tree7d58809b1c07513d58bea344d5395b1175acb7c0 /src/compiler/glsl/meson.build
parent215c9359ed1e71757b677787fb79aa4009c43605 (diff)
nir/linker: Add nir_build_program_resource_list()
This function is equivalent to the linker.cpp build_program_resource_list() but will extract the resources from NIR shaders instead. For now, only uniforms and program inputs are implemented. v2: move from compiler/nir to compiler/glsl (Timothy Arceri) v3: remove support for inputs, that is still WIP (spotted by Timothy Arceri) Signed-off-by: Eduardo Lima <[email protected]> Signed-off-by: Alejandro Piñeiro <[email protected]> Reviewed-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index 88a49c6997e..81d0fbea521 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -71,6 +71,7 @@ files_libglsl = files(
'gl_nir_lower_samplers_as_deref.c',
'gl_nir_link_uniform_initializers.c',
'gl_nir_link_uniforms.c',
+ 'gl_nir_linker.c',
'gl_nir_linker.h',
'gl_nir.h',
'glsl_parser_extras.cpp',