summaryrefslogtreecommitdiffstats
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
authorNeil Roberts <[email protected]>2017-11-28 13:39:44 +0100
committerAlejandro Piñeiro <[email protected]>2018-07-03 12:41:46 +0200
commit6677e131b806b10754adcb7cf3f427a7fcc2aa09 (patch)
tree90de6bec0f602da1534a0cc4089e2b3041821dba /src/compiler/glsl/meson.build
parent1fb9984d7e6d93fb174ff1fb57d2b3b8eda45515 (diff)
nir/linker: Add a pure NIR implementation of the atomic counter linker
This is mostly just a straight-forward conversion of link_assign_atomic_counter_resources to C directly using nir variables instead of GLSL IR variables. It is based on the version of link_assign_atomic_counter_resources in 6b8909f2d1906. I’m noting this here to make it easier to track changes and keep the NIR version up-to-date. Reviewed-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index 81d0fbea521..96536b80168 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -69,6 +69,7 @@ files_libglsl = files(
'gl_nir_lower_atomics.c',
'gl_nir_lower_samplers.c',
'gl_nir_lower_samplers_as_deref.c',
+ 'gl_nir_link_atomics.c',
'gl_nir_link_uniform_initializers.c',
'gl_nir_link_uniforms.c',
'gl_nir_linker.c',