summaryrefslogtreecommitdiffstats
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
authorJordan Justen <[email protected]>2017-10-27 01:04:53 -0700
committerTimothy Arceri <[email protected]>2017-12-08 16:44:35 +1100
commitebd9e789c40190862b28bbde8852c0b8b09df5ba (patch)
tree40dc82c3c711639037b4a3503a7cbdfe5834a8e1 /src/compiler/glsl/meson.build
parent219628c1180069cd92e4d01a3e527d2df9f4851c (diff)
glsl: Split out shader program serialization
This will allow us to use the program serialization to implement ARB_get_program_binary. Signed-off-by: Jordan Justen <[email protected]> Reviewed-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index 5b505c007a0..6aaa9bab05c 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -181,6 +181,8 @@ files_libglsl = files(
's_expression.h',
'string_to_uint_map.cpp',
'string_to_uint_map.h',
+ 'serialize.cpp',
+ 'serialize.h',
'shader_cache.cpp',
'shader_cache.h',
)